This is a public Forum  public

Topic

    Doug Freestone
    webbsite fails
    Topic posted April 16, 2013 by Doug Freestone, tagged Wireless plans, features, and network 
    2835 Views, 11 Comments
    Title:
    webbsite fails
    Content:

    I cannot get to this website from my HTC Incredible: http://www.swpc.noaa.gov/

    That site opens normally when I turn off 'Mobile Network' and use only WiFi in the phone.

    All other websites seem to work just fine from the phone despite recent service 'improvements'..

    Tech Support has no explanation, the site apparently opens from phones in Regina.

    I'm located SW of Saskatoon in the black hole known as Pike Lake where I get variously 0-3 bars (-95 to -105 dBm) from rural towers 25-40 km away.  Despite the marginal service level, data service has been acceptable, but barely so.

    Can anyone in the northern half confiirm this site failure?

     

    Comment

     

    • Logan

      Is there anyone in the in the northern part of the province who can test this?

      I tried it on my phone in Regina and as described above it worked fine.

    • Doug Freestone

      Thanks, Logan

      I was in Regina on the weekend and tried that problem website from northwest Regina where I had an excellent signal.  No Go!  Other sites seemed normal.   OTOH, two iPhones in the same room accessed that site with no problems, so back to the drawing board.

      Yesterday I installed the latest Firefox for Android and lo & behold, that problem website is no longer a problem.  It works just fine.  Not sure what's up with that, but since I use Firefox daily on my desktop, it's a keeper on the phone and the original Android  browser goes bye-bye.

      Still  a mystery, though.

      /df

       

    • Doug Freestone

      I started this thread a couple of weeks ago when my HTC Incredible would not open pages on the US Gov't website "www.swpc.noaa.gov".

      On April 22, I apparently 'solved' it when I replaced the native Android browser with Firefox and the webssite opend normally.

      On April 30, Igot a call from Tech Support informing me that there had been sopme fixes applied to a server or router and the website should not openj normally with any browser.  I tested it with the native Android browser and itdid indeed work.  That was April 30.

      Today,  that website will not open with EITHER Firefox or the native Android browser.   Firefox just responds "can't find the server..."

      Bu the formerly reticent Android browser now reports, "Destination could not be reached. (com.nokia.warlock.protocolstack.exceptions. Unresolved HostException:http://www.swpc.noaa.gov..."

      A simple Google search on "com.nokia.warlock"  (with quotes) returns huindreds of hits, none of which were helpful, but do indicate this not an isolated incident, many carriers were involved.

      Back to the drawing board, I guess.

      --

      /df

       

      .

    • Doug Freestone

      CORRECTION:

      Correcting the most glaring typo in my previous post:

      .."the website should not openj normally with any browser..."

      should read

      "the website should NOW open normally with any browser"

      UPDATE:

      This moorning May 3rd at 0745 CST the subject websites open just fine with the Android browser, but not with Firefox.

      Oh, well....

      --

      /df

       

       

    • NineSuns

      LOL; frustrating for sure, and who knows why. My mother regularily reports that she can't get one specific web site on occasion (using a PC). I spent hours on it trying to find a solution - or at least a cause, but it's still a mystery to me why it comes in some times and not others, when every other site will come in on that browser. I don't have an HTC (iPhone instead), but did go to the site on my iPad and it came in just fine (but you knew that). 

      I also did a quick search, but no good leads. So, I've seen the problem before on a PC, but never came up with a solution. I wish I could help more. 

    • Doug Freestone

      Thanks, NineSuns.

      FWIW, I have just received an inquiry from a friend who is a SaskTel DSL customer in Saskatoon and he has a similar difficulty with NOAA.GOV when accessing from Win-7/Firefox desktop.  He was unaware of my reported difficulties, we just share a common interest in these US Gov't sites.

      Meanwhile, I have no such problems with those sites from my desktop here, my Internet path to NOAA.GOV does not include any SaskTel network segments. 

      --

       

    • Logan

      This seems very confusing. I previously reported that I could open the website fine using Safari on April 23. I tried it again this morning and it didn't work with Safari or Chrome on my iPhone.

      I recently downloaded Puffin Web Browser, but have never used it. I decided to try it and it worked perfect. I don't know if the Google Play store has Puffin, but maybe take a look.

      It seems to be browser specific whether it works or not. The part I don't understand is the inconsistency, why it works one day and not the next is a mystery.

    • Sylvan Katz

      If one resolves the domain name for noaa.gov and to get the IP address and then use this in IE10 browser one get an error message with an email address of the web site adminstrator

      http://129.15.96.21/

      I emailed the noaa web administrators telling them about the difficulties in accessing their web sites from Sasktel ISP and I got the following response:

       

      This is bit boiler plate but I think your problem might be something many ISP's have faced few years back.  We get few of these now and than.  I suspect this is the issue.
       
       
      Problem seems to be you guys are blocking any dns packets return over 512 bytes regardless of udp or tcp.

      Can you check if your firewall devices or any devices has this enabled? also, if you are running bind for your recursion service / you can disable looking for more data packets that comes with RRSIG under the option tab,

      dnssec-enable no;

      to not ask for the long records that include DNSSEC data.

      Does a TCP query work while a UDP query does not? This could be a networking issue with eDNS packets. The problem may be that your ISP
      is blocking any DNS packets over 512 bytes, whether UDP or TCP.  Or it doesn't support the eDNS flag for UDP.


      The ISP should check their firewall devices or any devices that has this enabled for DNS proxy or DNS packet truncation.

      If the ISP is running bind, the simple thing would be to just not ask for the RRSIG or DNSSEC data on their recursion servers.

       
      Often firewalls do have eDNS proxy options, and they have various names for them.

      in JUNO on netscreens option i believe is udp_message_limit
      set di service dns udp_message_limit 512 - 4096

      in cisco might be something like
      fixup protocol dns maximum-length 4096

      or later IOS versions

      policy-map type inspect dns preset_dns_map
      parameters
      message-length maximum 4096
       
      I sure wish sasktel tech support would hurry up and solve this problem!

       

    • Doug Freestone

      UPDATE:

      As of 7:30 AM today/15th both browsers in my phone are opening the subject NOAA websites properly.   This behavior was first observed last evening and continues this morning.

      Is it fixed?    Hard to say.   Stay tuned.

       

    • Sylvan Katz

      At 8:15 this morning the noaa web site appear to be working. Fingers crossed that the problem has been resolved

    • NineSuns

      Sounds good gentlemen; thanks for reporting back. Perhaps it will have solved my mother's problem with the site she has trouble with too. Here's hoping it's a permanent fix. ;)